[Solutions] - Problème de créations de MOD ?!

Voir le sujet précédent Voir le sujet suivant Aller en bas

[Solutions] - Problème de créations de MOD ?!

Message par LightPhenix le Ven 18 Fév 2011 - 21:17

Sur ce topic seront répertorié les problèmes et leurs solution.
Donc si vous rencontré un problème, faites le savoir.

Si vous garder une image par défaut en PNG, qui porte le nom palette_5551, pour faire votre TMH, ou bien dans le dossier 002 ou 006, le jeu va freezer. (dans ce cas, faire un BMP, puis un TMH tout nouveau puis supprimer le dossier avec les PNG dedans ^^ )


Problème : Fichier introuvable ?!
Si vous avez des problèmes de création de MOD, lorsque vous entré votre nom de dossier, et qu'avant de vous demander le N° vous avez le message "Isn't a directory: C:/3rd/[votre nom de dossier]
Et que si vous entrée votre N° vous obtenais une suite de "fichier introuvable"
Alors, la solution est simple : Vous déplacer le dossier 3rd et tout son contenu dans C:/

Soit vous ouvrez MOD_Creation.bat dans un éditeur de texte, et vous remplacer la ligne
Code:
java -jar mhtrans.jar --rebuild C:/3rd/%dossier% 6
Par
Code:
java -jar mhtrans.jar --rebuild C:/LE CHEMIN OU EST VOTRE DOSSIER/3rd/%dossier% 6


Problème : Un TMH ce créer a coté du mod, et mon mod freeze : Thumbs.db
Il ce peux que quand vous aller créer le MOD, une erreur avec un certain nom de fichier "Thumbs.db" apparaisse. La solution la plus simple, est de faire comme plus haut, fait un TMH tout propre et supprimer le dossier.
En faite, Thumbs.db est un fichier caché de windows, qui sauvegarde les images miniature du dossier dans ce fichier. Et lorsque le programme lis le contenu du dossier, il lis ce fichier, et plante ...
Une solution pour les plus malin (et plus simple que refaire le TMH) c'est de créer un nouveau document texte, le renomme ren "thumbs.db" (il faut que les extensions soit affiché) et de le copier dans le dossier, et de cliquer sur "oui" pour remplacer, et ensuite de le supprimer. (mais ne pas revenir dans le dossier, sinon il va ce recréer ...)
Pour un moyen plus radical, il suffit de désactiver l'option de mise en cache des miniatures. (Tuto : http://www.commentcamarche.net/faq/617-windows-xp-fichiers-thumbs-db-et-vignettes )








LightPhenix a écrit:En transparence, tu n'as le choix que entre Noir ou Blanc, aucun niveau de gris sur la couche alpha n'est accepter Wink
Car au final c'est une image en 16 bit, avec seulement 1bit pour la couche alpha qui ne comprend que 0 ou 1 en valeur.

En plus la technique de couleur indéxée, elle s'applique sur ton image une fois "fini" en gros, tu travail comme tu veux les couleur, les calques et tout, comme si tu n'avais aucune limite Wink
Et une fois que tu as obtenue ce que tu veux, tu passe en couleur indéxée pour définir le nombre de couleur à un maximum de 256, et après, tu reviens en RVB, cette manip permet de réduire le nombre de couleur, qui reste donc a 256 après être repassé en RVB. Biensur, si tu remodifie après, il va falloir refaire la manip Wink


Un autre problème, qui concerne : Le Rathalos, La Rathian, le Diablos Noir et les Gigginox : La présence de fichier none.gim.
Je suis actuellement en train d'essayer de corriger le problème...
Mais pour le moment, les gigginox ne sont pas modifiable.
Et pour le Rathalos et La Rathian, il manque deux images (none.gim) ce qui vous empêcheras, dans un premier temps, de faire un MOD fonctionnel, ou, dans un deuxième temps, d'avoir un MOD incomplet.
Le Rathalos lui manque un fichier qui concerne les ailes. Mais si vous construiser un TMH avec les images seulement lisible, le MOD planteras. Si vous copier les gim dans le dossier _TMH, et que vous modifier le .bat (ou .sh pour linux) en rajoutant *.gim vous obtiendrais un MOD mal reconstruit. Bref, que de problème, donc je vous suggère de passer à un autre monstre pour le moment ^^


Dernière édition par LightPhenix le Mar 1 Mar 2011 - 18:28, édité 3 fois

______________________________________________________________________________________________________



NE RÉPOND PAS AUX MPs CONCERNANT LE JEU !
Le forum est là pour ça,donc profitez-en.
avatar
LightPhenix
Admin

Nombre de messages : 3900
Age : 26
Localisation : Pas très loin sur ta gauche
Rang : Fatalis Vert a pois rose
X-Tag : [FT]_lightphenix
Date d'inscription : 15/04/2007

http://gordemandeox.free.fr/

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par DeesTkuUt le Ven 18 Fév 2011 - 22:16

Merci pour la solution LP :tkt:
J'ai reussi a faire fonctionner mon mod ! :vivemoi:
EDIT: HELP !
Voila que j'ai une autre erreur sur un autre mod (c'est toujours le rathalos (je l'adore *o*))
L'erreur en question : 'java' n'est pas reconnu en tant que commande interne ou externe, un programme exécutable ou un fichier de commandes.
Franchement y'a qu'a moi que ce genre de chose arrive Evil or Very Mad
Si tu peut m'aider LP sa serait génial.
Voila le probleme en image : http://img28.imageshack.us/i/sanstitregk.png/
EDIT 2: c'est bon c'est regler il suffisait juste d'installer java ... :marteau: (j'ai utilise mon autre ordi et il n'avait pas java.
avatar
DeesTkuUt
Quest-Maker

Nombre de messages : 36
Age : 21
Localisation : Sur le dos d'un narga en plein rodeo ...
Rang : MHP3 rang 6
X-Tag : DeesTkuUt
Date d'inscription : 28/01/2011

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par [AD]tigrex-noir le Dim 27 Fév 2011 - 13:21

Salut,

j'aurais une question: Pour patcher les mods, je tape "F:\ISO\iso.iso" pour ouvrir dans le logiciel, mon iso se nomme bien "iso.iso" mais le patch ne fonctionne pas, pour tant le logiciel affirme que les mods ont été patché, cela me fais ça à tous mes mods, même ceux du pack de LP!
Quel est le problème ? Que dois-je écrire dans "ouvrir"?

merci d'avance!
avatar
[AD]tigrex-noir

Nombre de messages : 1580
Age : 24
Localisation : n'essayez pas de me chercher, vous risquez de le regretter ....
Rang : Je suis un tigrex!
Date d'inscription : 25/04/2008

http://www.monsterhunterunite.forumactif.com

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par FriendlyHunter le Dim 27 Fév 2011 - 13:44

J'ai une petite astuce pour vérifier si l' iso est bien patcher. Quand tu clique sur "PATCHER", regarde la diode de chargement de la mémory stick (orange). Si elle ne clignote pas c'est qu'aucunes données n'est transférées donc que ton iso ne se patche pas, si c'est le cas, je pense qu'il y a un souci avec l'adresse de ton iso. Enfin je suppose.
avatar
FriendlyHunter

Nombre de messages : 183
Age : 29
Localisation : 2éme cercle de l'enfer.
Date d'inscription : 24/03/2010

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par Drakhan le Dim 27 Fév 2011 - 14:55

Vérifie que ton ordi donne bien la lettre F: à ton périphique et quand tu dis que ton iso s'appelle "iso.iso", renomme le plutôt en MHP3 et quand tu lance le logiciel, ouvre et tape: LETTRE DE TON PERIPHERIQUE \ ISO \ MHP3.iso => le .iso n'est que l'extention de ton fichier.
avatar
Drakhan

Nombre de messages : 64
Age : 22
Localisation : En train de miner la tête d'une Rathian à coups de marteau ! Ou en train de percer un Rathalos à l'arc !
Rang : MHFU : HR 9 // MHP3rd : HR 4
Date d'inscription : 06/06/2009

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par LightPhenix le Dim 27 Fév 2011 - 15:27

Essaye sans le ".iso"

______________________________________________________________________________________________________



NE RÉPOND PAS AUX MPs CONCERNANT LE JEU !
Le forum est là pour ça,donc profitez-en.
avatar
LightPhenix
Admin

Nombre de messages : 3900
Age : 26
Localisation : Pas très loin sur ta gauche
Rang : Fatalis Vert a pois rose
X-Tag : [FT]_lightphenix
Date d'inscription : 15/04/2007

http://gordemandeox.free.fr/

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par [AD]tigrex-noir le Dim 27 Fév 2011 - 16:02

ça fonctionne!

le problème était bien dut au nom de mon ISO!

merci beaucoup
avatar
[AD]tigrex-noir

Nombre de messages : 1580
Age : 24
Localisation : n'essayez pas de me chercher, vous risquez de le regretter ....
Rang : Je suis un tigrex!
Date d'inscription : 25/04/2008

http://www.monsterhunterunite.forumactif.com

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par DeesTkuUt le Dim 27 Fév 2011 - 23:32

Alors voila,
j'ai un léger problème avec le tmh lorsque que je veut créer le 003 image d'un dossier d'une map (c'est la grande arène) :/
j'ai modifie les images que je voulais, que j'ai ensuite enregistré en .bmp dans _TMH en A8R8V8B8.
et voila mon problème: http://img59.imageshack.us/i/problememoddmaparene.png/
vous pouvez m'aider ?
avatar
DeesTkuUt
Quest-Maker

Nombre de messages : 36
Age : 21
Localisation : Sur le dos d'un narga en plein rodeo ...
Rang : MHP3 rang 6
X-Tag : DeesTkuUt
Date d'inscription : 28/01/2011

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par LightPhenix le Lun 28 Fév 2011 - 0:00

Pour les map, pas besoin de passer en BMP et par TMH, on peut laisser les 8888 en png et en laissant le dossier 003 et les image dedans, et sauter l'étape du TMH. Donc en lançant directement le MOD_Creation.
Le tmh va ce reconstruire tout seule, suffit de vérifier qu'il n'y as pas d'erreur ^^ (Genre des : Palette size)

______________________________________________________________________________________________________



NE RÉPOND PAS AUX MPs CONCERNANT LE JEU !
Le forum est là pour ça,donc profitez-en.
avatar
LightPhenix
Admin

Nombre de messages : 3900
Age : 26
Localisation : Pas très loin sur ta gauche
Rang : Fatalis Vert a pois rose
X-Tag : [FT]_lightphenix
Date d'inscription : 15/04/2007

http://gordemandeox.free.fr/

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par DeesTkuUt le Lun 28 Fév 2011 - 1:13

okok merci LP :tkt:
Seulement il faut que je re-enregistre mes BMP en PNG dans le dossier 003 image quoi Neutral
Bon je retourne de ce pas sur mon arène Twisted Evil
Une dernière question, il y a besoin de la couche alpha comme pour les monstres ??
(j'ai re enregister mes bmp en png, et je n'ai pas de couche alpha sur mes png car ce format ne les prend pas en charge)

avatar
DeesTkuUt
Quest-Maker

Nombre de messages : 36
Age : 21
Localisation : Sur le dos d'un narga en plein rodeo ...
Rang : MHP3 rang 6
X-Tag : DeesTkuUt
Date d'inscription : 28/01/2011

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par LightPhenix le Lun 28 Fév 2011 - 2:01

La couche alpha en BMP c'est pour la transparence. Le PNG gère la transparence par défaut sans couche alpha :tkt:

______________________________________________________________________________________________________



NE RÉPOND PAS AUX MPs CONCERNANT LE JEU !
Le forum est là pour ça,donc profitez-en.
avatar
LightPhenix
Admin

Nombre de messages : 3900
Age : 26
Localisation : Pas très loin sur ta gauche
Rang : Fatalis Vert a pois rose
X-Tag : [FT]_lightphenix
Date d'inscription : 15/04/2007

http://gordemandeox.free.fr/

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par Kono le Lun 28 Fév 2011 - 11:16

Par contre un mod avec des croix gammées, c'est moyen :tkt: Tu pourras pas le diffuser sur le forum, je sais c'est bête toussa, mais on a pas le choix :tkt:

______________________________________________________________________________________________________



Pensez à vos modo, éditez le titre de vos sujets et ajoutez le tag [Résolu] lorsqu'ils le sont. Ça nous fera gagner du temps.

Fan du grand SheperdOfSouls *o*



avatar
Kono
Admin

Nombre de messages : 3997
Age : 24
Localisation : Sur la banquise avec un pingouin célèbre
Rang : Libriste
X-Tag : Parce que Linux c'est le bien.
Date d'inscription : 05/01/2009

http://konosprod.free.fr/

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par DeesTkuUt le Lun 28 Fév 2011 - 13:10

dommage, il n'y a que cette image qui a des croix gammées Crying or Very sad mais je vais rectifier cette image :tkt:
bon, j'ai réussi a créer le map.mod (j'ai rectifier les erreurs de couleurs) mais lors du test la psp freeze Shocked
Donc je suis allé jeter un coup d'œil dans mes dossier arene_camp et arene_1 pour voir si il y avait bien tout et j'ai remarqué qu'il n'y avait dans aucun des deux le fichier 003_image.tmh, est-ce que sa a un rapport avec le freeze ? (j'ai regardé dans les deux dossiers après avoir crée le map.mod)
EDIT: Merci LP :tkt: , problème résolue, il suffit de supprimer les thumbs dans le dossier des images de chaque zones.
avatar
DeesTkuUt
Quest-Maker

Nombre de messages : 36
Age : 21
Localisation : Sur le dos d'un narga en plein rodeo ...
Rang : MHP3 rang 6
X-Tag : DeesTkuUt
Date d'inscription : 28/01/2011

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par MeTeOrA le Ven 4 Mar 2011 - 13:53

Bonjour tout le monde !! Very Happy

J'ai un problème au niveau de l'affichage du monstre.
En effet je modifie mon Gagua préféré, et le souci ... C'est que malgré la manip' suivi a la lettre, eh bin il est invisible le Gagua ninja
Je ne sais pas d'où ça peut venir, mais j'ai une piste : dans l'image que j'ai modifié avec Photoshop, au debut il y a des pixels blancs entre certaines parties du monstres, certains ont été recouvert, c'est grave ? euh
Et puis lors de l'execution de MOD Creation et TMH, je n'ai eu aucune erreur, pas de problème de 256 couleurs ou de Thumbs.db scratch
Merci d'avance Very Happy
Meteora king
avatar
MeTeOrA

Nombre de messages : 146
Age : 25
Localisation : Ardeche (07) .... D'ailleurs si il y a des hunters pres de la qui veulent faire du online ... MP :)
Rang : HR9 solo ( pas trop difficile mais bon faut etre patient ;))
X-Tag : [FA]Meteora
Merci à Moidekonoha et Yv. pour la config =)
Date d'inscription : 01/09/2009

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par LightPhenix le Ven 4 Mar 2011 - 14:12

Couche Alpha .... Noir = invisible.

______________________________________________________________________________________________________



NE RÉPOND PAS AUX MPs CONCERNANT LE JEU !
Le forum est là pour ça,donc profitez-en.
avatar
LightPhenix
Admin

Nombre de messages : 3900
Age : 26
Localisation : Pas très loin sur ta gauche
Rang : Fatalis Vert a pois rose
X-Tag : [FT]_lightphenix
Date d'inscription : 15/04/2007

http://gordemandeox.free.fr/

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par MeTeOrA le Ven 4 Mar 2011 - 15:04

Ah, tu veux dire qu'il faut régler sur Photoshop le calque alpha, mettre le curseur vers le blanc ?
Je suis sur CS5, merci je test Smile
EDIT : Trouvé, merci LP Very Happy
avatar
MeTeOrA

Nombre de messages : 146
Age : 25
Localisation : Ardeche (07) .... D'ailleurs si il y a des hunters pres de la qui veulent faire du online ... MP :)
Rang : HR9 solo ( pas trop difficile mais bon faut etre patient ;))
X-Tag : [FA]Meteora
Merci à Moidekonoha et Yv. pour la config =)
Date d'inscription : 01/09/2009

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par LightPhenix le Ven 4 Mar 2011 - 18:53

On vois que tu as bien suivi mon tuto Rolling Eyes
Fait sous Photoshop, et 'ai fait EXPRÈS d'oublier la couche alpha avant de sauvegarder pour montré de faire attention et de mettre en blanc >_<

______________________________________________________________________________________________________



NE RÉPOND PAS AUX MPs CONCERNANT LE JEU !
Le forum est là pour ça,donc profitez-en.
avatar
LightPhenix
Admin

Nombre de messages : 3900
Age : 26
Localisation : Pas très loin sur ta gauche
Rang : Fatalis Vert a pois rose
X-Tag : [FT]_lightphenix
Date d'inscription : 15/04/2007

http://gordemandeox.free.fr/

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par MeTeOrA le Sam 5 Mar 2011 - 12:32

Dsl si je t'ai frustré :p

En fait j'ai plutôt regardé le descriptif de la vidéo fait pas SoS, étant donné que chez moi, une vidéo de 6min je dois la recharger plein de fois avant de la visionner au complet Mad

Du très bon boulot en tout cas, je posterai quelques mods a l'occasion
:tkt:
avatar
MeTeOrA

Nombre de messages : 146
Age : 25
Localisation : Ardeche (07) .... D'ailleurs si il y a des hunters pres de la qui veulent faire du online ... MP :)
Rang : HR9 solo ( pas trop difficile mais bon faut etre patient ;))
X-Tag : [FA]Meteora
Merci à Moidekonoha et Yv. pour la config =)
Date d'inscription : 01/09/2009

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par hypancistrus le Sam 17 Mar 2012 - 16:42

Bonjour,

est ce que le fait de patcher un .mod dans l'iso en change la taille?

Le mmt me dit que c'est patcher etc, mais je ne voit aucun changement dans le jeu, serais ce dut à l'installation des données?si oui, comment la desinstaller?

Merci!
avatar
hypancistrus

Nombre de messages : 122
Age : 19
Localisation : Gers
Rang : mhf1: 5/5 mhf2:6/6 mhfu:9/9 3rd:6/6 2nd G:9/9
Date d'inscription : 19/08/2011

Revenir en haut Aller en bas

Re: [Solutions] - Problème de créations de MOD ?!

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum